Intro to Microsoft Excel

A spreadsheet is a computer program used to organize real world data, such as
a rolodex or check register, that allows the user to easily maintain and access
the information stored within it. Some advantages of a spreadsheet are that the
user can "program" it to perform certain functions automatically (such as
addition and subtraction) and its ability to hold almost limitless amounts of
data (entire filing cabinets can be represented in a single spreadsheet). Once
created, the spreadsheet can be quickly accessed, modified, and updated.
Today, we will be using Microsoft Excel 2003 to explore the program.
Microsoft Excel 2007 looks different, but works the exact same way. If you
have questions about Excel 2007, please let your instructor know

For more information on the Library and programs, visit www.bcpls.org
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Microsoft Excel Components
Before you get started with Microsoft Excel (commonly referred to as Excel), you will need
to locate and open it from the computer. It may be on your desktop.
From the computer desktop: Double-click on the Excel icon
Go to the Start menu if the Excel icon is not on the desktop:
Click ►Start ►Programs ►Microsoft Excel*
*Occasionally, Microsoft Excel will be in a folder called “Microsoft Office” or similar – this will make one
more step between “Programs” and “Microsoft Excel” in the diagram above.

Excel will open a blank page called “Book 1.”

Using the Browser’s Titlebar
This is a close-up view of the Title Bar, where file information is located. Notice the default title
"Book1." You will get a chance to rename your spreadsheet the first time you choose to save it.
Notice the three buttons on the right side, controlling program features. Remember that the X button
on the far right means close the program, the middle button is a toggle switch between full screen
and a small window, and the single line button on the left means minimize to the task bar.

The Menu Bar
The Menu Bar is a common site in almost all Microsoft Windows programs. It features text-based
menus, on which are listed virtually every option available to the user in the entire program. Each
menu expands when clicked (with the left mouse button), offering many options categorized by
specific tasks.
You can click on each of the words to see a menu of the tasks you can perform.
To see a menu:
1. Point with your mouse to a menu option
2. Click the left mouse button once to open a drop-down menu
3. Point with your mouse to a particular item
4. Click once with the left mouse button to select the item
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The Standard Toolbar

Toolbars provide “shortcuts” to commands also found in the Menu Bar. Toolbars are usually
located just below the Menu Bar, and exist to offer another way to perform the same task. As with
all Microsoft Windows programs, there are usually three ways in which to perform every task in
order to suit the user’s preferences.
Remember, if you can’t remember what an icon stands for, hover your mouse over it and a box will
pop up with the explanation!
The most commonly used commands in MS Excel are also the most accessible.
Some of these commands are:

NEW

SAVE
OPEN

PRINT PREVIEW
PRINT

COPY

PASTE

SORT

AUTOSUM

The Formatting Toolbar

The Formatting Toolbar offers options that can change the font, size, color, alignment, organization
and style of the text in the spreadsheet and the individual cells. For example, (starting from the left
side of the Toolbar) the “Arial” indicates the FONT of your text; the “10” indicates the SIZE of
your text; and so on.
This toolbar works the exact same way as the MS Word Formatting Toolbar. The main difference is
that the format changes will only affect the selected cell or cells, all unselected cells remain in the
default setting ("Arial" font, size "10").

Don’t forget
about the
special function
keys on your
keyboard!
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The Equation Editor

The equation editor is generally found below the main toolbar. The left side denotes which cell is
selected ("A1") and the right side allows you to input equations or text into the selected cell.
There are two ways to input information into a cell.
1. Select an individual cell and type the equation or text into the equation editor
2. Type the equation or text directly into the selected cell.
Equations (=sum(D5+E5)) will automatically be hidden inside the cell and can only be viewed
through the equation editor while the result of the equation will be in the cell.
Note: If any written text is longer than the cell width, then the spreadsheet will cover up any
portion longer than the cell width.

Want to Copy and Paste or
Undo and Redo like you do in Microsoft Word?

You can!
The same familiar options are available in Excel
for use anytime you need them!

Formatting Cells
Cells are the small rectangular boxes that make up the spreadsheet. All the information entered into
an Excel spreadsheet is entered into the cells.
The cell Width and Height will usually need to be adjusted to view all the information entered into
a cell
To adjust the cell width, move the mouse pointer in between two cell
columns in the column header. Hold down the left mouse button and
drag the mouse left to shorten the width or right to expand the width.
Notice that all cells within the column are automatically adjusted.
Adjust the cell height using the same method. Move the mouse cursor between
two rows, hold down the left mouse button and move the mouse up to decrease
the height, and down to increase the height.
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Formatting Cells, cont’d.
Before you begin entering data into a spreadsheet, you may already know what width and height
you want your cells to have. In this case, you can adjust the widths and heights of all cells by doing
the following:
Select the “square” between Column A and Row 1. This will select ALL the cells in the
spreadsheet. Click Format ► Row ► Height. You will now be asked to enter a numerical value
for “height.” Note that the default value is 12.75. Enter your own height value (10, 15, 20, 25, etc).
Repeat the same steps for Column width. Click Format ► Column ► Width. Note the default
value for the width is 8.43. Enter your own width value (5, 10, 15, 20, etc).
For any given cell or selected cells, you can also format the way your data is represented within the
cell(s). Select a single cell or multiple cells. Click Format ► Cells. The format window will now
appear giving you a wide variety of options on how to format your cell.

Number - This allows you to choose how to represent the numbers that are entered into a cell.
Alignment - This determines how the data will be aligned within the cell (left-side, centered, or
right-side).
Font - Select the type of font to be used within the cells.
Border - This option lets you choose what type of border, if any, you would like around the cells
or part of the cells.
Patterns - This allows you to change the background color of the cell.
Protection - This option allows you to “lock” the cell information so that other users will not be
able to make changes.
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To enter information (text, numbers, etc) into a cell, click in that cell and begin typing. To go to the
next cell, you can use your arrow keys, mouse, or your Tab key. If you want to edit cell information,
just click back on the cell to select it, then use the equation editor at the top to make changes.
The Formatting toolbar on MS Excel is exactly the same as the one used for MS Word. The biggest
difference between the two is that for MS Excel, the format is set for each individual cell. Therefore,
if you change the font, size and applied the bold option in cell C5, then this format will only be
applied to cell C5. All remaining cells will remain in default mode until they have been changed.
Sometimes you may only wish to adjust the format of one particular cell. In this case, simply select
the cell by clicking the mouse on it and make any necessary adjustments to the font, size, style, and
alignment. Other times, you may wish to adjust the text format of a group of cells, entire rows, or
entire columns.
Selecting a group of cells – Take a look at your spreadsheet and visualize which group of cells you
wish to select. Remember, in MS Excel all selected cells must be connected creating some sort of
highlighted "rectangle." Select the cell that would be the upper-left hand corner of your "rectangle."
Hold down the Shift key on your keyboard and use the arrows on the keyboard to expand the
selection of cells. You can also use your mouse to “click and drag” a selection.
Once the group of cells has been selected, you can make any necessary adjustments to the font, size,
style, and alignment and it will be applied to all the selected cells.
Selecting an entire row – Sometimes you may wish to format the text of an entire
row so that any data entered into the row, regardless of which column, will always
look the same. Select the Row Number with your mouse and note how the entire row
becomes highlighted. All text formatting changes are now applied to the entire row.
Selecting an entire column – Sometimes you may wish to format the
text of an entire column so that any data entered into the column,
regardless of which row, will always look the same. Select the Column
Letter with your mouse and note how the entire column becomes
highlighted. All text formatting changes are now applied to the entire column.

Inserting Rows and Columns
At some point, you may realize that you need to insert a row or column into your spreadsheet.
To insert a row, click on the row below where you wish your new row to be (remember to click on
the row number to highlight the entire row). Right click your mouse and select the insert option. A
new row will automatically be inserted and the row numbers automatically adjusted.
To insert a column, click on the column to the right of where you wish your new column to be
(remember to click on the column letter to highlight the entire column). Right click your mouse and
select the insert option. A new column will automatically be inserted and the column letters
automatically adjusted.
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Once you have organized your spreadsheet and entered in some data, you may find it useful to sort
that data according to certain criteria. Take a look at the checking account information represented:

MS Excel has the power to sort this information by either Check No. or Date (or any other Column
Description). First, select all the cells that represent the data to be sorted, including the header
descriptions (Check No., Date, Description, etc). You can do this using the keyboard, or clicking
and dragging your mouse. For this example you want to select rows 8-17 and all the columns with
information in them. The cells should look like this:

Using your mouse, select Data ► Sort and the Sort Window should appear.
Now, select the column you wish to sort by (in this case, we have
chosen "Date"). Do you want the dates to be in ascending or
descending order? Once you select OK the checking account
information will be sorted by the date of transaction.
If you do not have “column headers” (aka names at the top of
each column) the “sort by” options will be the column numbers.
If you want to sort an entire column, you can also use your
mouse to select the whole column (see page 6) and click the sort
button - you choose which one by if you want
ascending or descending. If there is other information
attached to what you are sorting, it will prompt you to
decide if you want to “expand the selection”. If you want your rows to stay intact (keep all the
related information together) you click yes!
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Auto Sums and Equations

One of the most powerful features of Excel is its ability to perform basic math functions on your
existing data. Excel can add, subtract, multiply, divide, find the average, and perform general
counting functions on the numerical data you entered. To enable this feature, select an empty cell
somewhere near the data for which you wish to perform a math function. This will be the cell where
the “answer” to your math function will appear.
Select the AutoSum icon from the tool bar.
Note the difference between selecting Σ (which immediately initiates the Sum command) or
selecting the ▼ symbol (which gives you a choice of which command you wish to initiate).
Within the selected cell, you will see an equation that looks something like this.

•
•
•
•
•
•

= - denotes that you have started an equation for the cell
SUM – tells you what the equation will do. In this case, the equation will add
together the selected cells.
( ) – parentheses contain the cells to which the math function will be performed.
D11 – this is the first cell to be included in the addition formula.
D17 – this is the last cell to be included in the addition formula.
: - indicates that all cells in between the first and last should be included.

Usually, the spreadsheet will "select" the cells that it thinks you wish to include. But you can
manually change the cell range by typing the desired cell range into the Formula Bar or using your
mouse to select the correct cells.
Press Enter to execute the formula.
Other math functions you can perform from the AutoSum icon are:
• Average - This will calculate the average of the selected cells
• Count - This function simply counts the number of cells selected.
• Max - this function will return the highest value of the selected cells.
• Min - this function will return the lowest value of the selected cells.
• There are even more complicated functions that Excel can do - but most of us will never
need to use them!
Remember - Excel equations are similar to programming languages, so have some patience and if at
first you don’t succeed - don’t be afraid to try again. It is not uncommon for Excel professionals to
create a wrong formula on the first try. Once you get an equation to work, you will technically be a
programmer!
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Printing Spreadsheets
To print your Excel document:
Click File ►Print from the Menu Bar and a print window will pop up on the screen.
Click OK for your document to start printing.
As with all commands in Excel, you can make changes along the way. From the Print Menu, you
can alter how many copies will be made, in what order the pages will be and much more.

Other useful tools are the Print Preview function, found alongside the Print command, and the
Page Setup function.
Print Preview will allow you to look over an exact copy of what will come out of the printer
before actually executing the print command. .
Page Setup will allow you to select the page order in which multiple pages will be printed,
the direction of the paper (often “landscape” is best for spreadsheets), and determine if the
Gridlines should be printed or not.

Saving Spreadsheets
When you come to a stopping point and want to leave the computer or close the program, it is
important to save your work (even if you are printing a hard copy — saving should be a reflex).
Click ►File ►Save from the Menu Bar to get started.
You can change the filename that Excel has chosen just by typing a new one in the File name box at
the bottom of the window that appears.
Excel will automatically save your document with the suffix “.xls” – this is simply a tag that
lets Excel know that your work is specific to this program. You do not have to type it – just
highlight what is there and write a new file name. (If you are using the newest version of
Excel it will have the suffix “.xlsx”)

To bring a saved document back up on the screen from Excel:
1. Click ►File ►Open from the Menu Bar.
2. Find where the file is located (which folder, that is) and click on the filename of the
document you want.
3. Click ►Open.

Finding Help
You can get help with MS PowerPoint by choosing Microsoft Excel Help or Show the Office
Assistant from the Help menu on the main menu bar.
Tutorials are also available on the Internet. Your instructor can help you with locating some of
these resources.
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